General

Included in ADAPT-Builder 2016.2 and later releases are enhancements to some basic modeling operations within the program. This document is intended to explain the new features and provide a concise overview on how to use these new and improved features. In addition, ADAPT-Builder 2017 introduces improvements made to tendon modeling and optimization. These are outlined in the ADAPT-Floor Pro 2017 Tendon Modeling Supplemental Manual located in the HELP menu of the program.

Undo/Redo Functions

Description:
The **Undo/Redo functions** have been extended to all program modeling functions. ADAPT Builder 2016.2 also includes enhanced stability of the **Undo/Redo functions**. In addition, the user now has the ability when creating components, for example slabs, openings, support lines and other continuously drawn components, to **undo** the last drawn vertex. When modeling users may accidently click a point in a location other than the intended location. If this happens, in previous versions, you could not delete the point and insert it again without finishing the drawing of the object. In ADAPT Builder 2016.2, and future versions, the user can now click on the **Undo** icon, press **CTRL-Z**, or press the **Backspace** key on the keyboard and the last vertex drawn will be removed. The user can then click a new vertex to the originally intended location.

Tools:

- **Undo** – Allows the user to undo recent modeling functions.
- **Redo** – Lets the user Redo the previously undone modeling function.

Pull Down Menu

- **Edit → Undo** ...
- **Edit → Redo** ...

Enter as a Hot-Key

Description:
The **ENTER** key was established as a shortcut option to close polygon modeling. **Close/End/Accept** was also added to the Right-click options.
These options are applicable to slabs, tendons, support lines, splitters, tributary regions, patch loads, area springs, tributaries and excluders. When modeling one of the above mentioned components the user can click the **ENTER** button on their keyboard or choose **Close/End/Accept** from the Right-click options to end the modeling function for the component.

**Dynamic Dimensioning**

**Description:**

**Dynamic Dimensions** (angular and linear) have been added to the user interface of ADAPT-Builder when creating new components such as slabs, walls, beams, openings, support lines, splitters, etc. The user can now start to draw a component and the program will show the length from the first point to the next point to be drawn as well as the angle from the global positive X-axis. After clicking the second point the dynamic dimensions will now be referenced from the end point of the first segment, and so on.

The **Dynamic Dimensions** feature within ADAPT-Builder also includes the use of **Projected Extension Lines**. The **Projected Extension Lines** are dashed lines that show up at 0, 90, 180, and 270 degree intervals and extend throughout the modeling screen.
When the **Projected Extension Lines** cross over another entity and the **Snap to Intersection** tool is active you can then snap to the intersection of the **Projected Extension Line** and the other entity it is crossing over.

In addition the user has the ability to lock either the length, angle or both. Once the user has started to draw their component, Right-clicking on the screen will open the **Dimension Input** and **Dynamic Dimension Settings** options.
Set Length/Angle:

Set Length/Angle options have been added to the Right-click options when drawing a component that uses Dynamic Dimensions. The user can access the Set Length/Angle dialog window by Right-clicking the screen while Dynamic Dimensions are visible and choosing the Dimension Input option in the Right-click options. In addition the D button on the keyboard is now a hot-key when Dynamic Dimensions are visible. The user can hit the D key on the keyboard and the Set Length/Angle dialog window will be displayed.

In the Set Length/Angle dialog window, the user can lock the length or angle of the segment of the component they are drawing. For example when drawing a slab region, the user can open the Set Length/Angle options window and type in 10 for the length and check the Lock Length option. After clicking 'OK' the length of the segment to be drawn will be locked at 10 feet or meters, depending on the units selected for the model. The user can then rotate the fixed-length segment to the desired angle. In the screen shots below, it is shown that independent of where the mouse pointer is located, only the angle changes relative to the global X-axis.

The user also has the option to lock the angle as opposed to the length. When locking the angle, the length will change but the angle of the slab segment will not. The images below show that the segment angle has been locked at 45 degrees. At this fixed angle, the segment length can be reduced or stretched along its path.
Dynamic Dimension Settings:

The Dynamic Dimension Settings have been added to the Right-click options when drawing a component that uses Dynamic Dimensions. The user can access the Dynamic Dimension Settings by Right-clicking the screen while Dynamic Dimensions are visible and choosing the Dynamic Dimension Setting option in the Right-click options. In addition, the S button on the keyboard is now a hot-key when Dynamic Dimensions are visible, the user can hit the S key on the keyboard and the Dynamic Dimensions Settings dialog window will be displayed. The Dynamic Dimension Settings dialog window controls the visual display of the Length, Angle or Projected Extension Lines (Ref Lines). The user has the option to turn on and off certain components of the Dynamic Dimensions. The user can also set the increment of the dimensions or angle so that the program snaps automatically to this increment.

Copy & Paste Commands

Description:

In ADAPT Builder 2016.2 and future versions, the Copy (CTRL+C) and Paste (CTRL+V) commands have been improved to function such that when a selected object or groups of objects are copied, the program immediately prompts for the insertion point of the object(s). In addition, the same functionality can be used to copy and paste items to different planes defined in a model.

Another feature added is the ability to copy and paste using a User-Defined Reference Point. The newly added Paste command only works when in Top View. A user may select objects and copy (CTRL+C) in other views, but when going to paste the copied entities the user must be change the view to Top View.

Copy & Paste Single Level:

In Single-Level modeling mode a user can now select components to be copied using Edit->Copy or selecting CTRL-C on the keyboard. This will copy the items to the clipboard. Once copied to the clipboard the user can go to Edit->Paste or select CTRL-V and the entities stored to the clipboard will become visible on the screen, dragged to any location and inserted. The user can also change reference levels to paste objects relative to the active reference level. This new and improved functionality can be used in place of using the Copy/Move command under the Modify menu.
The figure above shows the program after the user has selected items, copied the items by clicking **CTRL-C** and then selecting **CTRL-V** to paste the items. Note that an insertion point has not yet been selected to complete the paste function. This is evident from the message on the yellow bar at the bottom left of the screen. The items are shown on screen and move in unison with mouse movement so that the user has complete control over the objects insertion location. The copied entities will still be active to click and paste to another point such that the paste function works in continuous mode by default. To exit the **Paste** command the user can choose **Exit** from the Right-Click options or press the **ESC** button on the keyboard. The figure below shows the entities after being copied and pasted.

**Copy & Paste with user defined base point (CTRL+SHIFT+C):**

In using the basic **Copy** and **Paste** commands outlined in the above section, the program picks the insertion point for the copied objects. This point happens to be the first object created or the beginning vertex for the first polygon created. Oftentimes, the user does not recognize the object or vertex created first in modeling sequence, hence, the selection appears arbitrary. This location may not be the intended or desired reference point for the user. As can be seen in the following image, the items being pasted are being referenced from the end point of the fourth tendon horizontally-oriented from the bottom edge of the slab.
This makes it difficult to place the tendons in the correct position relative to the slab edges. For improved user-control over base reference and insertion points, the Copy and Paste functions can be based on a User Defined Base Point by pressing CTRL+SHIFT+C on the keyboard.

When copying the tendons the user can define their base point that is referenced for the Copy and Paste command. Select CTRL+SHIFT+C and the program will prompt the user to “Enter the Translation base reference point” in the User Information Bar.

The user can then click at any screen location acting as the reference point. For example, we have chosen the lower left corner of the slab for the User Defined Reference Point. The Paste command will then be automatically invoked and the items the user copied will be referenced from the location selected as the insertion point. The image below shows the tendons being copied from the lower left corner of the slab (the selected base reference location) instead of the previously shown location at the end of the fourth horizontal tendon.
The **Paste** command stays active and the user can paste the items as many times as needed. To exit the **Paste** command, click on the *ESC* button or Right-click and select *Exit*. Note that this option is only available when copying in the same level and not when copying from one plane to another.

**Copy & Paste Vertical:**

In Builder 2016.2 and future versions, the user has additional options for copying objects to different reference levels. Note that the use of the **Copy/Move Vertical** command under the **Modify->Copy/Move** menu is still an active and applicable approach. The new **Copy** and **Paste** functionality extends to multiple reference planes. To use this, select the components to be copied, select **Edit->Copy** or click **CTRL-C** on the keyboard to copy the items to the clipboard. Navigate to the desired plane to paste the copied items. Go to **Edit->Paste** or click **CTRL-V** and the entities that were copied will become visible on the screen. The items can then be dragged to any location at the active reference plane and pasted.

As an example, see the images below. The tendons at the Current Level are to be copied to an upper level. First we select the tendons and choose **Edit->Copy** or click **CTRL-C** to copy the tendons.
Next, navigate to the desired plane at which the tendons will be pasted. This requires choosing the desired plane as the active plane. To move planes the user can either click the **Active Level Up** button in the **Story Manager** toolbar, or open the **Reference Plane Manager** and choose the plane that they want to copy the tendons to and click on the **Set as Active** button then close the **Reference Plane Manager**. In the screen shot below the active reference plane is Plane 5.

After navigating to the desired reference plane, select **Edit-Paste** or click on **CTRL-V** to invoke the paste command and select the insertion point for the copied items.

**Copy & Paste relative to Origin:**

ADAPT-Builder 2016.2 includes the ability to paste copied items to its original relative X and Y coordinates using the **Copy & Paste Based on Origin** command. To use this command, select the items to be copied (in our example, the tendons). **Copy** the items by selecting **Edit->Copy** or clicking **CTRL-C** on the keyboard. Navigate to the desired level and invoke the **Paste** command by selecting **Edit->Paste** or clicking **CTRL-V** on the keyboard. Once the paste command is active, the copied items will be shown on screen and will move with the mouse pointer as they are in queue to be inserted. The image below shows the copied
tendons with the base point located at the end of the endpoint of the fourth tendon from the bottom of the slab and oriented horizontally.

The user can now select the screen location to paste. However, based on the selected tendon group reference point, placing the tendons at the correct location can be difficult. In this case, the user has the option to Paste the items at the model origin. To do this, select the O button on the keyboard. This will place the tendons at the same X and Y coordinate position they were located at on previous reference plane, but in the current active plane.

The image below shows the tendons pasted at the same position they were at when copied, but at the current active plane using the **Paste to Origin** command. Once the objects have been placed the **Paste** command will still be active. The user can continue to paste objects in different locations or end the **Paste** command by right clicking and choosing **Exit** in the Right-click options or hitting the **ESC** button on the keyboard.
**Copy & Paste Multi-Level:**

The **Copy** (CTRL+C) and **Paste** (CTRL+V) commands also apply in full-structure mode. In this mode the user can select a group of entities to be copied, select **CTRL-C** to copy the items and select **CTRL-V** to paste the items in a different location. It is important to note that the pasting of the objects must be performed in Top View. When performing this operation in full-structure mode the copied objects reference the active plane at the time the **Copy** command (CTRL+C) was invoked. The **Paste** (CTRL+V) function will locate the entities relative to the current active plane.

The **Copy** (CTRL+C) and **Paste** (CTRL+V) commands used in full-structure mode within the same active reference plane is straightforward. The user can copy a structure like that shown below and paste to a different location in top view without changing the active reference plane. This will result in a copy of all items located at the same level as in the original selected group of items.

![Plan and Elevation view of structure before copying](image1)

![Plan and Elevation Views after Copying](image2)

The **Copy** (CTRL+C) and **Paste** (CTRL+V) commands can also be used between reference planes. When the user copies a group of items, moves to a new reference plane, and pastes the items copied, the items will be inserted based on the current active
reference plane. For example, three lower levels of a 6-story structure can be copied and pasted to an upper reference level to create the upper three floors. The image below shows that the 3-story structure has been selected and that the active plane is Plane 3.

Select **CTRL-C** to **Copy** the items to the clipboard and using the Active Level Up or Active Level Down icons, navigate to the plane to act as the insertion reference plane. In this example, the insertion reference has been set to Plane 6 as shown below.

Switch the model view to Top View and **Paste** the items into plan by selecting **CTRL-V**. For this example it is important for the columns to align vertically. Snap the item in place based on the reference point of the copied items or click **O** to paste the objects with reference to the origin. When complete, select **ESC** on the keyboard or Right-click and select **Exit**. The resulting model shows the bottom 3 floors with columns copied to Planes 6, 5, and 4. When objects are pasted this way, they are inserted at the active plane downward.
If there are not enough reference planes either above or below to facilitate the number of levels copied along with the change of reference plane, the program will truncate the top or bottom of the copied items. The program will not add reference plane automatically to allow for all copied items to be inserted in this case.

The image below displays all levels as being selected and copied from a 6-story building where the current plane is the active plane.

If the active reference plane is selected as Plane 3, the view is switched to Top View, and the 6 selected levels are then pasted to the right of the original structure, the resulting group of inserted items are such that the top two levels are truncated and the bottom-most columns are referenced from Plane 3 downward.
Copy & Paste Column Duplication:

In ADAPT-Builder 2016.2 and future releases, the program has enhanced ability to detect overlapping columns when a column is copied and pasted at the location of an existing column. The program will not accept columns that are located at identical geometric centers and will prompt the user to delete one of the columns when this is detected. When the program detects column duplication during use of the copy and paste commands, the warning shown below will appear.

Two options are available: Select **OK** to continue to paste the columns and adjust them manually, or select **Cancel** to exit the warning and avoid duplication.

Copy & Paste Column Location:

In previous versions of ADAPT-Builder, when upper columns were copied to a different level, the selected columns would be pasted as lower columns at the active plane. This functionality has been improved in ADAPT-Builder 2016.2. Copied columns that are pasted to a selected active reference plane will retain their relative position to that plane. Upper columns will remain upper columns and lower columns remain lower columns. The image below shows a simple slab with four lower columns and one upper column. The upper column has been selected and copied to be pasted to another plane.
Select **CTRL-C** to **Copy** the upper column and then click **CTRL-V** to start the **Paste** command. Click on the endpoint of each of the remaining 3 columns to paste the upper column at the same position as the remaining 3 lower columns. The result shown below displays upper and lower columns at all 4 positions as in the original model.

**Snap to Perpendicular**

**Description:**

In ADAPT Builder 2016.2 and future versions, the **Snap to Perpendicular** tool has been improved to be active after the initial input of an item. In previous versions of the program, for example, if a user modified a slab edge for a slab containing tendons, the tendons would remain static and not extend to the new position of the slab edge. The user would be required to draw construction lines to relocate the end of the tendons relative to the new slab position. In the latest release, the user can now select the end point of the tendon, activate **Snap to Perpendicular**, and snap the end point of the tendon to the perpendicular projection point on the slab. This improvement is not limited to tendons and can also be used for Support Lines, Splitters, Beams, Line Loads, Line Supports, and Line Springs.

The image below shows a slab that has been modified such that the tendon endpoints are no longer touching the slab edge. In addition, the gap dimension between the edge of slab and the tendon ends is greater than the **Trim/Extend Tendon** command tolerance.
The **Snap to Perpendicular** tool can be used to easily relocate the tendon ends by selecting the ends and shifting them towards the slab edge where the perpendicular projection will allow the tendon to be snapped to the slab edge.